POStudios Forum

Tech Support => Gabriel Knight - 20th Anniversary Tech Support => Topic started by: bugReporter on August 15, 2015, 10:39:53 AM

Title: Android: not able to purchase part 3
Post by: bugReporter on August 15, 2015, 10:39:53 AM

after playing part 1 and 2 (in-app purchase done without any problems) I am now not able to buy part 3 (days 4-6).

Whenever I click on the corresponding icon with the lock on it, I just get a dialog box saying:
"ERROR.  Authentication is required. You need to sign into your Google account."
The only interaction possibility I have is an Ok-button, which closes the dialog box. There is no chance to enter my password.

The strange thing is, that for part 4, everything was normal. There, the dialog box with the price opened up where I could also enter my Google password. I did that hoping this would fix my problem with part 3, but it didn't. So I am now left with part 1, 2 and 4, but no 3 to continue with  :-[

I am using a Samsung Galaxy Tab S (SM-T800) with Android 5.0.2. I have tried restarting the program and the tablet many times. I also changed my Play Store setting from "authentication always required" to "authentication never required", but with no success. I just keep getting the above error message.

Searching for that error in Google shows that it seems to be no uncommon problem to developers when implementing in-app purchases. I hope you can help me. I really want to continue with the great game and I really wish, I had chosen the PC version without all this in-app purchase stuff.


PS: One more fact that might help you: When I got the game, I clicked in the icons of all parts in the menu to see, what they cost. If I remember correcty, the dialog box with the price opened up correctly for part 3. But I closed it and opened part 2 to buy that one. Maybe that changed the status of part 3 somehow???
Title: Re: Android: not able to purchase part 3
Post by: wayens on August 15, 2015, 10:34:49 PM
Hi, Holger, I'll ask one of our programmers.
But at least to the cancel, I had never seen it affect anything, but we can investigate.
Did you try to buy after Day 3 or did you try to buy from main menu's New Game section?
How did you end day 3?  Did you exit from Caz's house, cemetery, or police station?
Title: Re: Android: not able to purchase part 3
Post by: Oldbushie on August 15, 2015, 11:31:04 PM
The only thing I keep track of in game for in-app purchases is very simple. So cancelling out to look at other items wouldn't affect anything. Do you have any ad-blockers or antivirus installed on your tablet? We've had cases where antivirus was blocking in-app purchases for some people.

When you see the error, how long is it after you started up the app? Have you tried waiting a couple extra minutes after game launch to see if that helps before you try to purchase? It may not have finished authenticating before you tapped the button. I put in an extra fix that should hopefully address that in the next patch, but it's worth trying. Unfortunately there's no listener for when the initialization step is done so I can't show a "waiting for authentication" signal.
Title: Re: Android: not able to purchase part 3
Post by: bugReporter on August 16, 2015, 02:21:00 AM

thanks for your quick replies!
First the good news: For reasons unknown, now, after one day, everything was okay again. The correct dialog box opened up on part 3 and I was able to purchase it! So for me, the problem is solved, but still it was an annoying bug (perhaps on Google's side?), that shouldn't be there. After all, players should be able to buy, if they want to  ;)

To answer your questions:
First I tried to purchase directly after day 3. After restarting the game I got there from the main menu when clicking on "continue from checkpoint". I didn't open the New Game section (thought this was just to restart from the beginning). I think I ended day 3 after Caz's house.

I have no adblocker or antivirus installed. I have waited different times after game start until trying to purchase the game. The first time, the game was already running for 2 hours. Please note, that during all my tries, the correct purchase menue opened up for part 4, but not for part 3! I was even able to buy part 4. So it can't be a general "in-app purchase currently not possible" problem.

Anyway, now I am glad, I can continue. For me, you have created a very nice remake, given the limited budget. Beautiful graphics, especially the faces. Thanks for that!
Title: Re: Android: not able to purchase part 3
Post by: Oldbushie on August 16, 2015, 10:02:42 AM
There was also a bug in which it was possible to tap another icon when the first popup hadn't finished processing which may have caused the issue. At any rate, that bug has since been fixed too so it should be fine on the next patch. :)

I'm glad you were able to purchase and it's great to hear that you are enjoying the game!
Title: Re: Android: not able to purchase part 3
Post by: wayens on August 17, 2015, 06:17:14 PM
Picky network you have. ;>

Glad you can get through now and continue!  Enjoy the rest of the game!