Main Menu

Frustrating Arcade-Sequence: Stuck

Started by Doodle, February 18, 2011, 01:41:49 PM

Previous topic - Next topic


Hi PO-team,

I really like your game and appreciate all the time this must have cost you. However, to me, the arcade sequence with the horse and all that stuff is -while graphically incredible beautiful- a huge pain in the backside. I dont seem to get it: When the game said "dodge", i tried to click with the hand and/or walk cursor, but most of time, those dragons bit me to death. Clicking furiously, I somehow managed to reach the tower, find the key and open the door, but on the stairs, this strategy didnt work: When I point on the stairs, the cursor changes, but when I click, the narrator tells me that I am insane (hmph!) and to go up, not down. I wondered if the right timing is required, but after 10 to 20 attempts, i gave up. Any help? I really would like to see whats on the top of that tower..


Move the mouse over the upper part of the stairs and it will change to an arrow pointing up.  Same with the dodging area - if you move the mous it will automatically change to the appropriate cursor when the time is right.
Weldon Hathaway


Thanks for the effort - but this didnt work (perhaps a technical problem or a bug or something?). When I pointed on the left side of the screen, I see the down-pointing arrow with the "up, up, up"-message, but I never ever managed to see any other arrow...

I give up..


[spoiler]You may have actually triggered some cursor issues during the first part with all the extra clicking - during that part there's no extra clicking needed, just move hte mouse over the area where the "Dodge" icons are flashing and click at the right time after the mouse icon changes to match.

Also partway up the stairs you need to actually take the torch to progress.[/spoiler]
Weldon Hathaway


I took the torch and everything was fine (must have forgotten the golden rule of adventure-gaming to pick up everythings thats not bolted down  :-\ )

Thanks for your help and patience - the cutscene was really worth it!


Yeah sorry I didn't think of mentioning that sooner, that's my bad!  Glad you enjoyed that cutscene!
Weldon Hathaway


It seems that sequence is a bit demanding for slower computers, it makes it hard to click at the right time. It's probably a good idea to lower resolution. When it works properly, it's a nice change of pace in the game...


I keep dying after leaving the Carraige, what must i do and i dident light the Candle yet, because i dident know where or how



That's an excellent point I'll have to remember - this sequence is super heavy on graphical output so it may put more strain on some computers than the game normally does and lowering the settings or running it in a window could help quite a bit.

jobreton - No, it's not skippable.

daventry -[spoiler] After you leave the carriage you enter the tower.[/spoiler]
Weldon Hathaway


[spoiler]I noticed that too on my computer. As soon as i entered Dreamland, the game started to lag, even with no other applications running and in windowed mode.[/spoiler]
"Love can't be banished, even from this place. ... still less can it be banished from my heart."
"ENOUGH! Burden me not with thy poetry."-KQ6


Just as a comment, the dodging bit on the horse was HARD for me.  I kept losing the Dodge arrow and getting hit.  I tried not to click except when it was there, but sometimes it wouldn't show up.  Took about 10 times before I could finally get through that.  The rest was fun and I had no problems with the arrows then, but the horse part I really had trouble with.